The New Myth family: SprintPHP Bonfire Practical CodeIgniter 3

New Myth Media Blog

Serving the New Myth Media Family.

Practical CodeIgniter 3 Released

My new book about making the most of CodeIgniter 3 is out!

With the recent release of CodeIgniter v3.0, it was only a matter of time before we could announce the release of Bonfire v0.7.2. While this version includes CI v2.2.1, it also supports v3.0, even on the same installation of Bonfire (though you must modify the $system_path in public/index.php to switch CodeIgniter versions). The documentation includes full details for installing CI3 in Bonfire and configuring your Bonfire application to work with CI3.

Please note that CI3 support is in the early stages. Everything appears to be working fine, but it has not been through extensive testing, yet.

In addition to CI3 support and the v2.2.1 upgrade, we have included:

  • a number of bug fixes
  • more/improved documentation
  • a driver system for the library which converts the docs
  • minor Profiler improvements
  • updated jwerty.js to v0.3.2
  • improved offline mode
  • improved HTTPS support
  • support for using language files from the official CI translations repository